Squid Server Error on CentOS 6.2

Taking care of your Linux box.

Squid Server Error on CentOS 6.2

Postby mashkoor.qadir » Fri Apr 27, 2012 10:55 am

Dear All,


I have installed a and configured squid with CentOS 6.2.... so for i have simply configured it. but it is giving the error

ERROR
The requested URL could not be retrieved

--------------------------------------------------------------------------------

The following error was encountered while trying to retrieve the URL: http://google.com/

Unable to determine IP address from host name google.com

The DNS server returned:

TimeoutThis means that the cache was not able to resolve the hostname presented in the URL. Check if the address is correct.

Your cache administrator is root.


the main configuration file is here
# Recommended minimum configuration:
#
visible_hostname cache.redmath.com

#My network
acl rmnet src 192.168.0.0/24 # RFC1918 possible internal network

acl manager proto cache_object
acl localhost src 127.0.0.1/32 ::1
acl to_localhost dst 127.0.0.0/8 0.0.0.0/32 ::1

# Example rule allowing access from your local networks.
# Adapt to list your (internal) IP networks from where browsing
# should be allowed

#acl rmnet src 192.168.0.0/24 # RFC1918 possible internal network

acl localnet src 10.0.0.0/8 # RFC1918 possible internal network
acl localnet src 172.16.0.0/12 # RFC1918 possible internal network
#acl localnet src 192.168.0.0/16 # RFC1918 possible internal network
acl localnet src fc00::/7 # RFC 4193 local private network range
acl localnet src fe80::/10 # RFC 4291 link-local (directly plugged) machines

acl SSL_ports port 443
acl Safe_ports port 80 # http
acl Safe_ports port 21 # ftp
acl Safe_ports port 443 # https
acl Safe_ports port 70 # gopher
acl Safe_ports port 210 # wais
acl Safe_ports port 1025-65535 # unregistered ports
acl Safe_ports port 280 # http-mgmt
acl Safe_ports port 488 # gss-http
acl Safe_ports port 591 # filemaker
acl Safe_ports port 777 # multiling http
acl CONNECT method CONNECT

#
# Recommended minimum Access Permission configuration:
#
# Only allow cachemgr access from localhost
http_access allow manager localhost
http_access deny manager

# Deny requests to certain unsafe ports
http_access deny !Safe_ports

# Deny CONNECT to other than secure SSL ports
http_access deny CONNECT !SSL_ports

# We strongly recommend the following be uncommented to protect innocent
# web applications running on the proxy server who think the only
# one who can access services on "localhost" is a local user
#
# INSERT YOUR OWN RULE(S) HERE TO ALLOW ACCESS FROM YOUR CLIENTS
#
# Example rule allowing access from your local networks.
# Adapt localnet in the ACL section to list your (internal) IP networks
# from where browsing should be allowed

http_access allow rmnet

http_access allow localnet
http_access allow localhost

# And finally deny all other access to this proxy
http_access deny all

# Squid normally listens to port 3128
http_port 8080

# We recommend you to use at least the following line.
hierarchy_stoplist cgi-bin ?

# Uncomment and adjust the following to add a disk cache directory.
#cache_dir ufs /var/spool/squid 100 16 256

# Leave coredumps in the first cache dir
coredump_dir /var/spool/squid

# Add any of your own refresh_pattern entries above these.
refresh_pattern ^ftp: 1440 20% 10080
refresh_pattern ^gopher: 1440 0% 1440
refresh_pattern -i (/cgi-bin/|\?) 0 0% 0
refresh_pattern . 0 20% 4320

the resolve .conf file is as
nameserver 127.0.0.1
nameserver 10.16.6.56

and also host name entry as my severs name
instead of that it gives the same message ho to get rid of this.

Thanks in advance.


--------------------------------------------------------------------------------

Generated Fri, 27 Apr 2012 05:14:42 GMT by cache.redmath.com (squid/3.1.10)
mashkoor.qadir
Lance Naik
 
Posts: 32
Joined: Mon Dec 20, 2010 10:27 pm
Yahoo Messenger: mashkoor.qadir@yahoo.com
Location: Karachi

Re: Squid Server Error on CentOS 6.2

Postby azhar_748 » Fri Jul 06, 2012 12:11 pm

It seems to be the problem is in your ACL definition.
Define ACL in proper syntax like mentioned below.

acl allow-all src "/etc/squid/acl/allow-all-ips" ## All net Allowed IPS ##################
acl servers-ips src "/etc/squid/acl/servers-ips" ## Server IPS ###########################
acl accountsip src "/etc/squid/acl/accountsip" ## Accounts & HR IP's ##################
acl accountsallow dstdomain "/etc/squid/acl/accountsallow" ## Accounts & HR Allow Sites ############
acl urlregex url_regex "/etc/squid/acl/urlregex" ## Words Rejected if in URL #############
acl voltadown dstdomain "/etc/squid/acl/voltadown" ## Avoid URL Rejection ##################
acl managers src "/etc/squid/acl/managers-ips" ## Managers IP's ##################
acl allownet src "/etc/squid/acl/allownet-ips" ## Limited Net Allow Ips ################
acl managers-block dstdomain "/etc/squid/acl/managers-blocksites" ## Blocked for Managers #################
acl block-sites dstdomain "/etc/squid/acl/block-sites" ## Blocked for Below Managers ###########
acl D-M src "/etc/squid/acl/dm-ips" ## DM IP's #######################
acl DM-allow dstdomain "/etc/squid/acl/dm-sites" ## DM Allow Sites #######################
acl A-M src "/etc/squid/acl/am-ips" ## AM IP's ##############################
acl EXE src "/etc/squid/acl/executive-ips" ## Executive IP's #######################
acl proc src "/etc/squid/acl/proc-ips" ## Proc-ips #############################
acl proc-allow dstdomain "/etc/squid/acl/proc-sites" ## Proc Allowed Sites ###################
acl officers src "/etc/squid/acl/officer-ips" ## Officers Ip's ########################
acl off-allow dstdomain "/etc/squid/acl/off-sites" ## Officers Allowed Sites ###############


http_access allow localhost
http_access allow servers-ips
http_access deny yahoo-msg
http_access deny msnmime
http_access deny msngw
http_access deny yahoo-msg
http_access allow allow-all
http_access deny urlregex
http_access deny !accountsallow urlregex
http_access deny !voltadown urlregex
http_access deny !EXE urlregex
http_access deny managers-block
http_access allow managers
http_access deny block-sites
http_access allow allownet
http_access allow accountsip accountsallow
http_access allow D-M DM-allow
http_access allow A-M DM-allow
http_access allow EXE DM-allow
http_access allow proc proc-allow
http_access allow officers off-allow
azhar_748
Cadet
 
Posts: 2
Joined: Fri Dec 18, 2009 8:37 am

Re: Squid Server Error on CentOS 6.2

Postby aquiline » Mon Jul 09, 2012 1:18 pm

ERROR
The requested URL could not be retrieved
--------------------------------------------------------------------------------
The following error was encountered while trying to retrieve the URL: http://google.com/
Unable to determine IP address from host name google.com
The DNS server returned:
TimeoutThis means that the cache was not able to resolve the hostname presented in the URL. Check if the address is correct.
Your cache administrator is root.

Try to set DNS Options in Squid.conf and see the results..
dns_retransmit_interval 15 seconds
dns_timeout 15 minutes // Adjust according to your requirement..
dns_nameservers 127.0.0.1 8.8.8.8 207.218.192.38 207.218.192.39// Set IPs of DNS Servers
// Also "pdnsd" is best solutions, you may configure and test it with squid for fast name resolution.
Sh@Ring is Le@Rning
aquiline
Company Havaldaar Major
 
Posts: 178
Joined: Sat Nov 20, 2004 5:56 pm
Location: Attock-#-Junction


Return to “%s” Administration

Who is online

Users browsing this forum: No registered users and 1 guest